SimpleLTC not vulnerable to Heartbleed bug

Ken BellSimpleLTCLeave a Comment

By now you’ve likely heard about the Heartbleed bug, the browser security vulnerability affecting online services and accounts worldwide. We wanted to provide an update you so you have clear information about the security and reliability of SimpleLTC’s long-term care software products. What is the Heartbleed bug? Heartbleed is a … Read More